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Lab Session 01: Introduction to Microsoft Office: Word 2013 
 

 

Objective:   

1. Getting used to Graphical User Interface in Windows Operating Systems. 

2. Understanding what word processors are and learning how to prepare a broad range of 

documents by using Microsoft Word. 

As the Windows Operation Systems have GUI, applications written for them have very good 

graphical interfaces, compared with the older applications written in the time of non-GUI 

operating systems like MS-DOS. Nowadays any person in a modern society, without having to 

have job related with computers, is, and should be, able to use many different applications on 

PCs. These applications include word processors, spreadsheets, etc. 

 
Word Processors:          

 

Microsoft word is a sophisticated word processing package that provides a range of features for 

document creation and formatting, including many desktop publishing type features, graphics 

and drawing utilities. 

 

 MS Word Usage:  
 

Word can be used to produce many document types including: 

 Letters 

 Labels 

 Memos 

 Reports 

 Curriculum Vitae 

 Advertisements 

 

How to Start with MS Word: 
 

 Click “START”→PROGRAMS→MICROSOFT OFFICE→MICROSFT WORD 

 Double click on MY COMPUTER→Open SYSTEM DRIVE→Open PROGRAM 

FILES→Open MICROSOFT OFFICE Executable files are present. 

 

 
 

Document: 
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When you start Word, a new, empty document file is automatically created, so you face an 

empty page. A document file is a file that contains information that user can view or hear. 

 

The Cursor: 

It is the visual screen element that indicates our exact position in the document. 

The Insertion Point: 

It is a flashing screen element that indicates the position in the document where text will be 

entered when we are typing. 

The Mouse Cursor: 

It is the on-screen graphic representation of the position of the mouse. 

 

BARS:    

Title Bars         

Displays the name- the type of document.  

Tab Bar: 

Click any of the words on this row to see tab options in the category. 

 

 
 

 
 

The Ribbon is the panel at the top portion of the document. It has seven tabs: Home, Insert, 

Page Layout, References, Mailings, Review, and View that contain many new and existing 

features of Word. Each tab is divided into groups. 

Each of the tabs contains the following tools:  

Home: Clipboard, Fonts, Paragraph, Styles, and Editing.  

Insert: Pages, Tables, Illustrations, Links, Header & Footer, Text, and Symbols 

Page Layout: Themes, Page Setup, Page Background, Paragraph, Arrange 

References: Table of Contents, Footnote, Citation & Bibliography, Captions, Index, and Table 

of Authorities 
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Mailings: Create, Start Mail Merge, Write & Insert Fields, Preview Results, Finish 

Review: Proofing, Comments, Tracking, Changes, Compare, Protect 

View: Document Views, Show/Hide, Zoom, Window, Macros  

 

Using the tabs 

 

Office Button:  

 

Create a new Document: 

 Select NEW or press CNTRL+N 

 New creates a new, empty document 

Open an existing Document: 

 Select OPEN or press CNTRL+O 

 Opens a document which was created and saved before 

Closing a Document: 

 Select CLOSE or click close icon 

 Closes the currently open, active document 

Saving a document: 

 Select SAVE or press CNTRL+S 

 Saves the document to a disk (permanent storage device) 

Save as: 

 Select SAVE or press CNTRL+S 

 Used to save another (one more) copy of a file, with a different name. 

Print a Document: 

 Used to take a print-out of the document. 

 

HOME TAB 

Cut: 

 select CUT or press CNTRL+X 

 Removes the information from an application and places it on the clipboard. 

Copy: 

 select COPY or press CNTRL+C 

 Copy leaves the information in an application and places a copy of it on the clipboard. 

Paste: 

 select PASTE or press CNTRL+V 

 Copies the information from the clipboard and places it into an application. 

Select All: 

 press CNTRL+A 

 Used to select the whole document. 

Font: 

 Select FONT 

 Used to change the style of the written text. 

Bullets and Numbering: 

 Select BULLETS AND NUMBERING 

 Used to insert numbers or any sign before each line 
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Changing Case: 

 Open format menu select CHANGE CASE 

 Used to change the case of the letters by applying small capital or all capital formatting. 

Undo Typing: 

 press CNTRL+Z 

 Used to cancel the last action (operation) you have made 

Repeat Typing: 

 press CNTRL+Y 

 Used to do a cancelled action once again 

Find: 

 press CNTRL+F 

 Used to search for some word or sentence in your document. 

Background: 

 Open format menu select BACKGROUND 

 Used to give a color to the document. 

 

VIEW TAB 

Web layout: 

 Used to create a web page document. 

Print layout: 

 Used to see how text, graphics and other elements will be positioned on the page. 

Document Map: 

 Displays the lists of headings in the documents. 

 

INSERT TAB 

Header and Footer: 

 select HEADER AND FOOTER 

 Used to do a cancelled action once again, 

Break: 

 Open insert menu select BREAK 

 Used to insert page break, column brake, text wrapping break. 

Symbol: 

 Open insert menu select SYMBOL 

 Used to insert any symbol which is not present on the keyboard. 

Insert Table: 

 select INSERT TABLE 

 Used to insert table consisting of any number of rows and columns  

Picture: 

 Open insert menu select PICTURE 

 Used to draw or insert any picture. 

 

 PAGE LAYOUT 

 

Page Numbers: 

 Select PAGE NUMBERS 
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 Used to insert page numbers on the top, bottom, centre, of the document. 

Columns: 

 select COLUMNS 

 Used to divide the written text in any numbers of columns. 

Border and shading: 

 Select BORDERS AND SHADING 

 Used to insert borders and color to the page. 

Text Formatting 
The formatting is the easiest way to change many attributes of text. 

 

STYLE MENU:  
 

This allows a quick formatting with a consistent and professional look. 

 

FONT MENU: 

 

This allows you to change the style of the formatting from the shown list. 

This sentence is written using “Times New Roman” type. 

This sentence is written using “Courier New” type. 

This sentence is written using “Arial” type. 

Font Size: 

We can change the font size by entering value in this box. 

 This sentence is written with size 8.  

 This sentence is written with size 20. 

Font Style:  

It is use to bold, italicize, and underline the text 

 This is an italic sentence. (Ctrl+I) 

 This is a bold sentence. (Ctrl+B) 

 This is an underlined sentence. (Ctrl+U) 

 This is both italic and underlined.  

 This is underlined and bold.  

 This is italic & underlined & bold. 
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Alignment:  

Text can be aligned to left, right, or centre of the page or it can be justified across the page. 

Increase/Decrease Indent: 

Using this we can change the indents of a paragraph in relation to the side of the page. 

Bullets and Numbers: 

Use to put numbers or sign before a line. 

 

WORKING ON TEXT 

Selecting Text 

 

 With Mouse 

1. Move your mouse pointer to the beginning of the text you want to select 

2. Click and hold the left mouse button 

3. Move the mouse to the end of the text you want to select. 

4. Release the mouse button. 

 

 With Keyboard 

1. Move the blinking cursor, by using the arrow keys, to the beginning of the text you want to 

select 

2. Press and hold the shift button 

3. Move the cursor to the end of the text that you want to select 

4. Release the shift button 

When a text is selected, you see it highlighted. Now, you can do many operations on the selected 

text. ex: move (cut-paste), copy (copy-paste), underline, change size, type, color, etc) 

 

Copying or Moving a selected text: 

To copy or move a text the first thing you have to do is to select it. Then click the Copy or Cut 

item depending on what you want to do. (Cut is used to move). Move the cursor to the position 

that you want to insert the selected text. Click Paste in the Edit menu. 

 

Insert A Table 

To insert a table into your document, click the Insert table item, enter the number of rows and 

columns and click OK. Here is a table with 6 rows and 5 columns: 

 

 
 

Inserting Equations In Your Document: 

To insert an equation into a document, click the Insert tab and using that you can insert equations 
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Some other necessary Commands 

• By using Line spacing commands, the distance between sentences can be arranged.(Single 

space, Double Space…etc.)For this command, from Home tab, Paragraph should be selected 

and from there “line spacing” can be arranged. 

• By using Effect commands, Superscripts and Subscripts can be written. For this command, 

from Home tab, Font  should be selected and from there “Effects” can be arranged. 

• By using Footnote command, some necessary footnotes can be written. For this command, 

from References tab, Footnote should be selected. 

• By using Header and Footer commands, Some texts can be written to the top or bottom of your 

sheet.(such as date, name…etc.) . For this command, from Insert tab, Header and Footer 

should be selected. 

 

Lab Task: 

1. Type a paragraph of about 50 words, then apply formatting. Text must be justified, add 

page borders and change the colour of page background. 

2. Include your name and roll number in the header field.  

3. Insert page number at bottom centre position. 

4. Insert a table that has 3 rows and 4 columns. The title of columns should be ID, Name, 

Surname, and Age. Fill in the first row with these titles. Into the second row, write 

yourself, and into the third, write a friend of you. 

Lab Assignment: 

 Create Curriculum Vitae (CV). After introductory portion add objective, education, work 

experience (if any), interests and references.  

 Write a report of not more than two pages, on different types of computer systems namely 
microcomputers, minicomputers, mainframes, super computers. The report should be 
properly formatted with appropriate indentations, and font styles with single line spacing and 
the specified alignment: 1 cm from left, 1 cm from top. You may use additional styles like 
drop cap and columns. Include your name and roll number in the header field. Also, the total 
market in 1985 for the products and services of the top 100 companies in he computing 
industry is given below as percentages. Present this information in graphical  
form.    

Microcomputers - 10.18%   ;   Minicomputers - 11.18%   ; Mainframes - 6.8% ; 

Data communications - 7.46%   ;   Peripherals - 27.23%   ; Software - 7.63% ; 

Services - 5.72%   ;   Maintenance - 11.56%   ; Other - 2.19%  

 

Attach your printed output. 
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Lab Session 02: Exploring the Advanced Features of Microsoft 
Word 
 

Objective:  To gain knowledge about advanced features of word.  
 

Macros: 
 
What is a Macro? 
 
“A Macro automates a task performed repeatedly or on a regular basis”. Macros are these 
series of commands and actions recorded and saved. The Macro is then run to automatically 
repeat the recorded series of commands and actions. 
 
Advantage: 
 
Macros are advanced features that can speed up editing or formatting you may perform often in 
a Word document. Series of actions can be completed in single step.   

Instructions for Creating a Macro: 

 

 Click the View Tab on the 

Ribbon. 

 Click Macros 

 Click Record Macro 

 Enter a name (without spaces) 

 Click whether you want it 

assigned to a button (on the Quick Access Toolbar) or the keyboard (a sequence of 

keys) 

 To assign the macro a button on 

the Quick Access Toolbar: 

o Click Button 

o Under the Customize 

Quick Access Toolbar, 

select the document for 

which you want the 

Macro available. 
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o Under Choose Commands:  Click the Macro that you are recording 

o Click Add 

o Click OK to begin Recording the Macro 

o Perform the actions you want recorded in the Macro 

o Click on Macros 

o Click on Stop Recording Macros 

 

 To assign a macro button to a keyboard 

shortcut: 

o Click Keyboard 

o In the Press New Shortcut 

Key box, type the key sequence that 

you want and click Assign 

o Click Close to begin recording the 

Macro 

o Perform the actions you want 

recorded in the Macro 

o Click on Macros 

o Click on Stop Recording Macro 

 

 

Modify the Macro Button: 
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To modify the button do the following: 
In the right window of the Customize the  
Quick Access Toolbar window, select  
the Macro button by clicking on it. 
 
 
 
 
Then click the Modify button. 
 
 
 
This will open a window displaying Icons 
for the button. 
Select an Icon by clicking on it. 
In the Display Name: field enters a name of  
your own choice.  
 
 
Click the OK button. 
 
 
 
 
 
 
 
Click the OK button at the bottom of the  
Word Options window to save the  
changes. 
 
 
 
Note:  The new Macro button is  
now added to the Quick Access Tool  
Bar. 
 
 
 
 
 
 
 
 
 
 

 

Begin Recording the Macro: 
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When the Word Options window closes,  
the system will begin recording Mouse 
and Keyboard inputs as a Macro. 
 
This will be indicated by: 

 Mouse Pointer icon now has an  
attached recording cassette. 

 Stop Recording and Pause  
Recording buttons on the  
Macro Icon. 

Click the Pause button to pause  
recording the Macro. 
 
After selecting the sequence of formatting,  
select the Macro and click the Stop  
Recording button. 
 
Note:  The Mouse Pointer will return to  
normal indicating, recording has stopped.  
 
The formatting steps are now saved as a  
Macro and can be used to format  
automatically future documents. 
 
 
Creating Web Pages: 

Simple web pages can be created in Word using the Save as 

Feature.  In a web document, you can insert pictures and hyperlinks.  To view the document as 

you would a web page: 

 Click the View Tab on the Ribbon 

 Click the Web Layout Button in the Document Views Group 

 

Entering Text: 
To enter text into the document, simply begin typing.  If you want to adjust the layout of the 

page and text, you should use tables to format the page properly. 

Hyperlinks:  
Hyperlinks, or links, allow the reader to click on text and go to another web site.  To create a 

hyperlink: 
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 Select the text that will be the link 

 Click the Insert Tab of the Ribbon 

 Click the Hyperlink Button on the Links Group 

 Type in the web address, or URL, of the link 

 Click OK 

 

Saving Web Pages:  
To save a web page: 

 Click the Office Button 

 Move the cursor over Save As 

 Click Other Format 

 Under Save as Type, click Web Page 

 Type in the name of the document (without 

spaces) 
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Mail Merge: 

 

Mail merge is very useful when you want to create a set of documents that are essentially the 

same but each document contains unique elements such as a person‟s name, address, greeting 

line, etc. Creating each document with different elements individually would take hours. When 

you use the mail merge feature, some of the content in the document remains the same while the 

selected element will be different in each document. 

 1.    Start a Mail Merge 

 Click the “Mailings” tab > “Start Mail 

Merge”> “Step by Step Mail Merge 

Wizard…” 

2.    Select Document Type  

 From the Mail Merge task pane, select 

“Letters”. 

 Click “Next: Starting document”. 
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3.    Select the Starting Document 

 

You will have three options to start your mail merge document: 

 

a)    You can use the currently opened document as your mail merge document. 

b)    You can select one of the ready-to-use mail merge templates. 

c)    You can open an existing document and use it as your mail merge main document. 

  

In this example, we‟ll be using the currently opened document.  

 Select the “Use the current document” radio button, and 

click the “Next: Select recipients” link. 

4.    Select Recipients 

 

In the third step, you‟ll need to choose a method to attach the data 

source that contains the element that you need changed on each 

individual document (e.g. first name, last name, address, etc.) for 

your recipients. There are three methods to choose from: 

  

a)    Use an existing data source that you‟ve created/saved earlier. 

b)    Use names from a Microsoft Outlook
®
 Contacts list. 

c)    Create a new database of names and addresses. 

 

In this example, we‟ll show you how to create a new database of 

your recipients from scratch and use it in the mail merge. 

 To create a new database, select the “Type a new list” radio 

button, and click the “Create” button. 

 

 In the “New Address List” 

dialog box, enter the 

information (title, first name, 

last name, address, etc.) for each 

recipient. Click the “New 

Entry”button to move to the 

next record. If there is no 

information for a particular 

field, don‟t worry, leave the box 

blank. When you are done, click 

on the “OK” button. 
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 To save the database, 

give the file a name, and 

click the “Save” button. 

 

 

 

 

 

 If you want to sort, filter, 

find duplicate entries, 

etc., use the options 

under “Refine recipients 

list” section then click 

the “OK” button. 

 

 

 

 

 

 

 

 

 

 

 

 Click the “Next: Write your letter” link to proceed to 

the next step. 

 

 

5.    Write Your Letter 

 

In this step, you write the content of the letter that you‟ll be sending to your recipients. 
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 Type the content (you 

can add graphics as 

well) that you want to 

include in your letter 

 

 

 

 

 

 

 To add recipient information to your letter, click a location in the document and click the 

“Insert Address Block”. (You can also use the greeting line and other options in the list to 

add more 

information). 

Click “OK” to 

continue. 

 

 

 

 

 

 When you finish editing the main document, click “Save” or “Save As” from the File 

menu. To proceed to the next step, click “Next: Preview your letters”. 
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6.    Preview Your Letters and Complete the Merged 

 

 

Here you can review your merged data, one letter at a time. You 

can also make changes to your recipient list or personalize 

individual letters. Click the “Next: Complete the merge” link to 

merge the variable information with the form letter, and output the 

merge result. 

 

  

Now you can print the letters and send them!  

 

 

 

 

Lab Tasks: 

 

1. Develop a macro which performs these tasks: 

 Make font bold, italic, underlined with font size=14, font face=Tahoma and font 

color = green. 

 Checks for Spelling & Grammar as well. 

 Adds your name as watermark. 

2. Develop a web page which contains following pages: 

 Home Page 

 Education Info 

 Contact 

 

 

Lab Exercise: (Should be submitted in next Lab) 

 

Create a word document, using mail merge wizard, which produces individual information 

reports for a list of students in the form of a table, including their first name, last name, father‟s 

name, home address, phone number, email addresses, and home page address as hyperlinks (if 

any). Enter few sample records. Table should be properly formatted.  

 

Remember to include your name and roll number in the header field. Get a printout to be 

attached here, of the page that contains only field name and not any records. Also attach 1 

sample report containing actual data. 

 

 

Attach the printed output. 
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Lab Session 03: Introduction to Microsoft Excel 
 

Objective:   To understand how to work in MS Excel. 

 

The Microsoft Excel Window: 

 

The Title Bar: 

 

The Menu Bar: 

 

Toolbars: 
 

The Standard Toolbar & Formatting Toolbar 
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Worksheets: 

 

Microsoft Excel consists of worksheets. Each worksheet contains columns and rows. The 

columns are lettered A to IV (256); the rows are numbered 1 to 65536. The combination of a 

column coordinate and a row coordinate make up a cell address. For example, the cell 

located in the upper left corner of the worksheet is cell A1, meaning column A, row 1. Cell E10 

is located under column E on row 10. You enter your data into the cells on the worksheet. 

The Formula Bar: 

 
Formula Bar 

The cell address displays in the Name box on the left side of the Formula bar. Cell entries 

display on the right side of the Formula bar 

The Status Bar: 

  

Status Bar  

Entering Numbers as Labels or Values: 

In Microsoft Excel, you can enter numbers as labels or as values.  

Labels are alphabetic, alphanumeric, or numeric text on which you do not perform mathematical 

calculations.  

Values are numeric text on which you perform mathematical 

calculations. If you have a numeric entry, such as an employee 

number, on which you do not perform mathematical 

calculations, enter it as a label by typing a single quotation mark 

(') first.  
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Formatting Numbers: 

You can format the numbers you enter into Microsoft Excel. You can add commas to separate 

thousands, specify the number of decimal places, place a dollar sign in front of the number, or 

display the number as a percent in addition to several other options. 

before formatting      after formatting 

 

 

1. Move the cursor to cell A5.  

2. Type 1234567.  

3. Press Enter.  

4. Move the cursor back to cell A5.  

5. Choose Format > Cells from the menu. The Format Cells dialog box will open.  

6. Choose the Number tab.  

7. Click Number in the Category box.  

8. Type 2 in the Decimal Places box.  

9. Place a check mark in the Use 1000 Separator box.  

10. Click OK. The number should now display with two decimal places. The thousands 

should now be separated by commas.  

Adding a Dollar Sign to a Numeric Entry: 

1. Move the cursor to cell A5.  

2. Choose Format > Cells from the menu. The Format Cells dialog box opens.  

3. Choose the Number tab.  

4. Click Currency in the Category box.  

5. Make sure there is a "$" in the Symbol box.  

6. Click OK. The number displays with a dollar sign.  

 

Alternate Method: Formatting Numbers by Using the Toolbar: 

1. Move the cursor to cell A6.  

2. Type 1234567.  

3. Press Enter.  

4. Move the cursor back to cell A6.  

5. Click twice on the Increase Decimal icon to change the number format to two decimal 

places. Clicking on the Decrease Decimal icon decreases the decimal places.  

6. Click once on the Comma Style icon to add commas to the number.  
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7. To change the number to a currency format, click Currency Style format.  

8. Move the cursor to cell A7.  

9. Type .35 (note the decimal point).  

10. Press Enter.  

11. Move the cursor back to cell A6.  

12. Click the Percent Style icon to turn .35 to a percent. 

Performing mathematical calculations: 

Making Numeric Entries 

In Microsoft Excel, you can enter numbers and mathematical formulas into cells. When a 

number is entered into a cell, you can perform mathematical calculations such as addition, 

subtraction, multiplication, and division. When entering a mathematical formula, precede the 

formula with an equal sign. Use the following to indicate the type of calculation you wish to 

perform: 

+ Addition 

- Subtraction 

* Multiplication 

/ Division 

^ Exponential 

 

Performing Mathematical Calculations 

The following exercises demonstrate how to 

perform mathematical calculations. 

1. Addition 

1. Move your cursor to cell A1.  

2. Type 1.  

3. Press Enter.  

4. Type 1 in cell A2.  

5. Press Enter.  

6. Type =A1+A2 in cell A3.  

7. Press Enter. Cell A1 has been added to cell A2, 

and the result is shown in cell A3. . 

2. Subtraction 

1. Press F5. The Go To dialog box opens.  

2. Type B1 in the Reference field.  

3. Press Enter. The cursor should move to cell 

B1.  

4. Type 5 in cell B1.  

5. Press Enter.  

6. Type 3 in cell B2.  

7. Press Enter.  

8. Type =+B1- B2 in cell B3.  
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9. Press Enter. Cell B1 has been subtracted from B2, and the result is shown in cell B3. 

3. Multiplication 

1. Hold down the Ctrl key while you press "g" (Ctrl-g). 

The Go To dialog box opens.  

2. Type C1 in the Reference field.  

3. Press Enter. You should now be in cell C1.  

4. Type 2 in cell C1.  

5. Press Enter.  

6. Type 3 in cell C2.  

7. Press Enter.  

8. Type =C1*C2 in cell C3.  

9. Press Enter. Cell C1 is multiplied by cell C2 and the 

result is displayed in cell C3.  

4. Division 

1. Press F5.  

2. Type D1 in the Reference field.  

3. Press Enter. You should now be in cell D1.  

4. Type 6 in cell D1.  

5. Press Enter. 

6. Type 3 in cell D2.  

7. Press Enter.  

8. Type =D1/D2 in cell D3.  

9. Press Enter. Cell D1 is divided by cell D2 and the result is displayed in cell D3.  

 

Lab Task: 

 

1. Take any five numbers then find 

 sum 

 average 

 min  

 max 

 division 

 

 

 

 Assignment: 

 Create the worksheet. Type in the labels, the student numbers, the test results (which are 

out of 100). The total marks and the class averages for each test must be calculated. The class 

average for test 1 is simply the average of the marks obtained in that test.  
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Lab Session 04: Functions in Microsoft Excel 
 

Objective:   To understand how to work in MS Excel. 

Functions: 

Microsoft Excel has a set of prewritten formulas called functions. Functions differ from 

regular formulas in that you supply the value but not the operators, such as +, -, *, or /. For 

example, you can use the SUM function to add. When using a function, remember the following: 

 Use an equal sign to begin a formula. 

 Specify the function name. 

 Enclose arguments within parentheses. 

 Use a comma to separate arguments. 

Here is an example of a function:  =SUM (2, 13, A1, B27) in this function: 

 The equal sign begins the function. 

 SUM is the name of the function. 

 2, 13, A1, and B27 are the arguments. 

 Parentheses enclose the arguments. 

 A comma separates the arguments. 

Typing a Function: 

1. Open Microsoft Excel.  

2. Type 12 in cell B1.  

3. Press Enter.  

4. Type 27 in cell B2.  

5. Press Enter.  

6. Type 24 in cell B3.  

7. Press Enter.  

8. Type =SUM (B1:B3) in cell A4.  

9. Press Enter. Microsoft Excel sums cells B1 to B3.  

Alternate Method: Entering a Function by Using the Menu: 

1. Type 150 in cell C1.  

2. Press Enter.  

3. Type 85 in cell C2.  

4. Press Enter.  

5. Type 65 in cell C3.  

6. Press Enter. Your cursor should be in cell C4.  

7. Choose Formulas  from the menu.  

8. Click Sum in the Select A Function box.  

9. Click OK. The Functions Arguments dialog box opens.  
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10. Type C1:C3 in the Number1 field, if it does not automatically appear.  

11. Click OK. Microsoft Excel sums cells C1 to C3.  

12. Move to cell A4.  

13. Type the word Sum.  

14. Press Enter.  

Calculating an Average: 

You can use the AVERAGE function to calculate the average of a series of numbers. 

1. Move your cursor to cell A6.  

2. Type Average. Press the right arrow key to move to cell B6.  

3. Type =AVERAGE (B1:B3).  

4. Press Enter. The average of cells B1 to B3, which is 21, will appear.  

Calculating Min: 

You can use the MIN function to find the lowest number in a series of numbers. 

1. Move your cursor to cell A7.  

2. Type Min.  

3. Press the right arrow key to move to cell B7.  

4. Type = MIN(B1:B3).  

5. Press Enter. The lowest number in the series, which is 12 appears.  

Calculating Max: 

You can use the MAX function to find the highest number in a series of numbers. 

1. Move your cursor to cell A8.  

2. Type Max.  

3. Press the right arrow key to move to cell B8.  

4. Type = MAX(B1:B3).  

5. Press Enter. The highest number in the series, which is 27, appears.  

Note: You can also use the drop-down menu next to the Sum icon to calculate minimums and 

maximums. 

Calculating Count: 

You can use the count function to count the number of items in a series. 

1. Move your cursor to cell A9.  

2. Type Count 

3. Press the right arrow key to move to cell B9.  

4. Click the down arrow next to the Sum icon.  
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5. Click Count.  

6. Highlight B1 to B3.  

7. Press Enter. The number of items in the series, which is 3 appears.  

Filling Cells Automatically: 

You can use Microsoft Excel to fill cells automatically with a series. For example, you can have 

Excel automatically fill in times, the days of the week or months of the year, years, and other 

types of series. Days of the week and months of the year fill in a similar fashion. The following 

demonstrates filling the days of the week: 

1. Move to Sheet2.  

2. Move to cell A1.  

3. Type Sun.  

4. Move to cell B1.  

5. Type Sunday.  

6. Highlight cells A1 to B1.  

7. Bold cells A1 to B1.  

8. Find the small black square in the lower right corner of the highlighted area. This is 

called the Fill Handle.  

9. Grab the Fill Handle and drag with your mouse to fill cell A1 to B24. Note how the days 

of the week fill the cells in a series. Also, note that the Auto Fill Options icon appears.  

 

10. Click the Auto Fill Options icon.  

11. Choose the Copy Cells radio button. The entry in cells A1 and B1 are copied to all the 

cells highlighted.  

12. Click the Auto Fill Options icon again.  

13. Choose the Fill Series radio button. The cells fill as a series from Sunday to Saturday 

again.  

14. Click the Auto Fill Options icon again.  

15. Choose the Fill Without Formatting radio button. The cells fill as a series from Sunday to 

Saturday, but the entries are not bolded.  

16. Click the Auto Fill Options icon again.  

17. Choose the Fill Weekdays radio button. The cells fill as a series from Monday to Friday.  

Cell Addressing: 

Microsoft Excel records cell addresses in formulas in three different ways, called absolute, 

relative, and mixed. The way a formula is recorded is important when you copy it. 
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1. Relative cell addressing 

When you copy a formula from one area of the worksheet to another, Microsoft Excel records 

the position of the cell relative to the cell that originally contained the formula. The following 

exercises demonstrate: 

1. Go to cell A7.  

2. Type 1. Press Enter.  

3. Type 2. Press Enter.  

4. Type 3. Press Enter.  

5. Go to cell B7.  

6. Type 7. Press Enter.  

7. Type 8. Press Enter.  

8. Type 9. Press Enter.  

9. Go to cell A10.  

Now you can enter a formula via following exercise 

1. You should be in cell A10.  

2. Type =.  

3. Use the up arrow key to move to cell A7.  

4. Type +.  

5. Use the up arrow key to move to cell A8.  

6. Type +.  

7. Use the up arrow key to move to cell A9.  

8. Press Enter.  

9. Look at the Formula bar while in cell A10. Note that the formula you entered is recorded 

in cell A10.  

Copying by Using the Menu: 

You can copy entries from one cell to another cell. To copy the formula you just entered, follow 

these steps: 

1. You should be in cell A10.  

2. Copy the contents of cell. Moving dotted lines appear around cell A10, indicating the 

cells to be copied.  

3. Press the Right Arrow key once to move to cell B10.  

4. Paste here. The formula in cell A10 is copied to cell B10.  

5. Press Esc to exit the Copy mode.  

Compare the formula in cell A10 with the formula in cell B10 (while in the respective cell, 

look at the Formula bar). The formulas are the same except that the formula in cell A10 

sums the entries in column A and the formula in cell B10 sums the entries in column B. The 

formula was copied in a relative fashion. 
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2. Absolute Cell Addressing 

An absolute cell address refers to the same cell, no matter where you copy the formula. You 

make a cell address an absolute cell address by placing a dollar sign in front of both the row and 

column identifiers. You can do this automatically by using the F4 key. To illustrate: 

1. Move the cursor to cell C10.  

2. Type =.  

3. Use the up arrow key to move to cell C7.  

4. Press F4. Dollar signs should appear before the C and before the 7.  

5. Type +.  

6. Use the up arrow key to move to cell C8.  

7. Press F4.  

8. Type +.  

9. Use the up arrow key to move to cell C9.  

10. Press F4.  

11. Press Enter. The formula is recorded in cell C10.  

Copying by Using the Keyboard Shortcut: 

Now copy the formula from C10 to D10 

Compare the formula in cell C10 with the formula in cell D10. They are the same. The 

formula was copied in an absolute fashion. Both formulas sum column C. 

3. Mixed Cell Addressing 

You use mixed cell addressing to reference a cell that is part absolute and part relative. You can 

use the F4 key. 

1. Move the cursor to cell E1.  

2. Type =.  

3. Press the up arrow key once.  

4. Press F4.  

5. Press F4 again. Note that the column is relative and the row is absolute.  

6. Press F4 again. Note that the column is absolute and the row is relative.  

7. Press Esc 
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Create conditional formulas: 
 

 Create a conditional formula that results in a logical value (TRUE or FALSE) 

 Create a conditional formula that results in another calculation or in values other than 

TRUE or FALSE 
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Lab Task: 

1. Take any five cells then merge them. 

2. In cells A1 and A2, type 1000 and 2000 respectively.  

3. Use auto-complete to fill in cells A3 to A8. 

Lab Assignments: 

 
1. Design a TEMPERATURE CONVERTER from Celsius to Fahrenheit and Fahrenheit to 
Celsius.Present the Converter with appropriate design. Formulas for conversion are as follows:  
[°C] = ([°F] − 32) · 5/9  
[°F] = [°C] · 9/5 + 32  
Also report the weather conditions as HOT if the temperature exceeds 35°C, WARM if the 
temperature is between 20°C to 35°C and COLD if the entered temperature is below 20°C. 

 
2

and cos and tell at which angle these values are equal. 

 

Attach the printed output. 
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Lab Session 05: Introduction to Features of Microsoft Power 
Point 

 

Objective:  To gain knowledge about advanced features of power point and how to make 

presentations in power point.  
 

Introduction: 
 

Power Point is a system in the Microsoft Office Suite that enables you to present information in 

office meetings, lectures and seminars to create maximum impact in a minimal amount of time. 

Power Point presentations can amplify your message, accelerate the information being absorbed 

and assist with comprehension enabling faster decision making. 

 

What is Presentation?: 

 

A presentation is a collection of data and information that is to be delivered to a specific 

audience.  A PowerPoint presentation is a collection of electronic slides that can have text, 

pictures, graphics, tables, sound and video.  This collection can run automatically or can be 

controlled by a presenter. 

 

Interface: 
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 Microsoft Office Button: Allows creating, opening, saving, printing and sending 

documents etc. 

 

 Quick Access Toolbar: Customizable toolbar that contains commands that you use very 

frequently. You can place the quick access toolbar above or below the ribbon. 

 Ribbon: Contains at least seven tabs containing many features grouped together. Only 

commonly used features are displayed. To view additional features, click on the arrow at 

the bottom right of each group. 

 View Choices: Allows viewing in different styles. Zooming feature is also included. 

 Navigation: Can be performed through the Slide Navigation menu on the left side of the 

screen. Used to move between slides and outline. 

 Mini Toolbar: A new feature in Office is the Mini Toolbar.  This is a floating toolbar 

that is displayed when you select text or right-click text.  It displays common formatting 

tools, such as Bold, Italics, Fonts, Font Size and Font Color.  
 
 
Making Presentation: 

 To create a new presentation, click   and select New. Either choose a blank template 

or choose from any existing templates/online templates. 

  To save a presentation, click  and use Save or Save As… to save on same location 

or on new location respectively. 

 To add a new slide, click New Slide under Home tab or right click on the left side panel 

and choose New Slide. 

 A template can be changed/selected later from Design tab as well. You can change 

colors, fonts, effects and background styles from the same tab. 

Working with Text: 

 To enter some text, first select the slide and then select the text box. 

 You can perform copy and paste, cut and paste, undo and redo, spell check and thesaurus, 

find and replace etc on the text. (Refer to MS Office Word lab) 

 Text formatting can be performed as taught in last MS Office Word lab. 

Adding Content & Graphics: 

 You can also insert additional text boxes by selecting Text Box from Insert tab. A text 

box can be resized as desired by dragging the sides of the textbox. 

 Bulleted and numbered lists are preferred while making presentations. Nested lists can 

also be used when desired. 

 You can add table, textbox, header & footer, date & time, slide number, movie and sound 

etc from Insert tab. 

 Graphics can also be inserted by using picture, clip art, photo album, shapes, smart art, 

and chart and word art from Insert tab. 



Department of Computer Engineering Page 35 
 

Slide Effects & Animations: 

 Slide transitions are effects that are in place when you switch from one slide to the 

next.  To add slide transitions, select the desired transition from Animations tab. 

 You can add transition sound and increase transition speed as well. 

 Slides can be advanced on mouse click by default but can be changed to specific time 

interval as well. 

 To add animation, select the object and click on Custom Animation from Animations 

tab. Choose from different available effects. 

 Click Preview to view how the animation will look like. 

 You can choose to run slide show from beginning, from current slide or setup custom 

slide show from Slide Show tab. 

Viewing & Printing: 

 You can create speaker notes by using Notes Page option from View tab. 

 There are different viewing options available under View tab as well. 

 Slide Master is used to manage all slides within a document at once. 

 Handout Master and Notes Master perform same tasks as performed by Slide Master. 

 Different printing options are available as well. 

 Macros can also be recorded from the View tab. 

 Print Layout: You are able to select how you would like your slides to be printed by 

selecting the drop down arrow next to the Fill Page Slides command. 

- Then, click on the format would like your slides to printing. The different options are: 

 Full Page Slides – print out with each slide on a full page 

 Handouts - print out with up nine slides per page 

 Notes Page - print out of one slide per page including any notes you may have 

added in the Notes Pane while creating your presentation 

 Outline View - print out of your text from all of your slides in an outline format. 

- Once you select your printing format, a preview of your slides will appear. When 

you're ready to print, click the Print command. 

 

Lab Tasks: 

 

Make a Presentation on any topic; (maximum 12 slides) it should have all the features of MS 

Power point you‟ve practiced above. 

 

Attach a printed copy 
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Lab Session 06: Flowcharts 
 
Objective:  To gain knowledge about word‟s flowcharting tools allow you to create diagrams 

that are clear and easy to read. 

Flowcharts Basics: 

Flowcharts are composed of shapes and connecting arrows. Most flowcharts will utilize the 

following three shapes. 

 

Creating Flowcharts Shapes 

Drawing a start block:  

Every process has a starting point and the 

majority of flowcharts begin with the start block. 

To draw a start block: 

 From the Insert ribbon, click on the button 

labeled Shapes. 

 

 From the shapes menu, navigate to the 

Flowchart submenu and click on the menu item 

marked with a rounded rectangle. 

 

 Your cursor should now be a +. Press and hold 

the mouse pointer to create your starting block. 

Release the mouse button when the rectangle is 

large enough. 
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Drawing a Process block: 

 Returning to the Shapes menu click on the first 

rectangle in the Flowchart region 

 

 Draw the rectangle following the process 

described above. 

 

 

Drawing a Decision Block: 

 From the shapes menu, click on the diamond 

located in the Flowchart region.  

 

 Draw the diamond following the process 

described above. 

 

 

Inserting Text Inside a Shape: 

 

Once you have drawn shapes on your flowchart, you can insert text within the shape. To insert 

text into a shape: 

 

 

 Right click on the shape. 

 From the menu that appears, select Add 

text. 

 

 Word will display a light blue color 

border around the shape, and a flashing 

insertion point  cursor inside the shape. 

 Type the text you wish to display within 

the shape. 

 Click the mouse button outside of the 

shape and the blue border will disappear. 
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Customizing Flowcharts Shapes: 

 

Once you have drawn the shapes on your flowchart, you can customize them to make your 

diagram more readable. 

 

Moving a Shape: 

 Click on the shape that you wish to move. 

 Place your cursor over the edge of the shape. 

 Word will display a cursor with 

four arrows. 

 

 Click and drag the shape to its new 

location. 

 Release the mouse button when you 

are satisfied with new location of 

your shape. 

 

 

Resizing a Shape: 

 Click on the shape that you wish to 

resize. 

 Place your cursor over one of the 

round selection handles on one of 

the corners of the shape. 

 Click and drag to resize the shape. 

 Release the mouse button when you 

are satisfied with the new size of the 

shape. 

 

Changing the shape’s color: 

 Click on the shape whose 

background color you 

wish to change. 

 From the format ribbon, 

navigate to the Text Box 

Styles tab. 

 From here, click on the 

Shape Fill button to give 

your shape color. 

 

 



Department of Computer Engineering Page 39 
 

 

 

 

 

Creating styles for your button: 

 From the Shape Fill 

menu, you can apply 

different effects (Texture, 

gradient) to the color of 

your button. 

 

Customizing the shape border: 

Occasionally you may wish to 

change the color or styles of 

your shapes border. 

 

 

 

Changing the border’s width: 

 After clicking on the 

shape outline, click on the Weight. 

 From the menu, choose the new 

width for the border of your shape. 

 

 Similarly you can change the style 

of the border by exploring the 

Dotted and Patterns menus of the 

Shape outline menu. 

 

Removing a shapes border: 

 From the Shape Outline menu, click 

on No Outline.  

 

 

 

 

Connecting Flowcharts Shapes: 

 

Once you have drawn the shapes in your flowchart and added text 

to each shape, you can draw arrows to connect your flowchart 

shapes in sequence. 

 

Drawing an arrow: 

 From the Insert ribbon, click on the Shapes button. 
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 From the Shapes submenu, click on the appropriate arrow. 

 

 

 

 

 

 

Adding Labels to Your Flowchart: 

 

Arrows originated from the decision blocks 

should almost always be labeled. To label your arrow, you will use a custom text box with no 

background color and no border. 

From the Insert ribbon, go to the Text tab and click on the Text Box. 

 

 

 

Lab Tasks: (Attach printed copy) 

 

1. Draw a flowchart to find the sum of the first 50 natural numbers. 

2. Draw a flowchart to find the largest of three numbers A, B, and C. 

3. Draw the following. 
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Department of Computer Engineering Page 42 
 

Lab Session 7-A: Introduction of MATLAB 
 

Objective: To understand the basic features of MATLAB.  

 

Equipment and software: Personal Computer loaded with MATLAB  

 

Operating system:Windows XP, Windows 7, Windows 8 etc... 

 

Theory: 

 

MATLAB, which stands for MATrix LABoratory, is a state-of-the-art mathematical software 

package, which is used extensively in both academia and industry. It is an interactive program 

for numerical computation and data visualization, which along with its programming capabilities 

provides a very useful tool for almost all areas of science and engineering. 

As you might guess from its name, MATLAB deals mainly with matrices. A scalar is a 1-by-1 

matrix and a row vector of length say 5, is a 1-by-5 matrix... One of the many advantages of 

MATLAB is the natural notation used. It looks a lot like the notation that you encounter in a 

linear algebra. This makes the use of the program especially easy and it is what makes MATLAB 

a natural choice for numerical computations. The purpose of this experiment is to familiarize 

MATLAB, by introducing the basic features and commands of the program. 

MATLAB is case-sensitive, which means that a + B is not the same as a + b. 

The MATLAB environment allows the user to: 

 Manage variables 

 Import and export data 

 Perform calculations 

 Generate plots 

 Develop and manage files for use with MATLAB. 

 

 

To start MATLAB: 

 

START > PROGRAMS >MATLAB (folder) > MATLAB 

Or shortcut creation/activation on the desktop 
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Display Windows is shown following…. 

 

 

Getting Help: 

Type one of following commands in the command window: 

 help – lists all the help topic 

 help topic – provides help for the specified topic 

 help command – provides help for the specified command 

 help – provides information on use of the help command 

 help win – opens a separate help window for navigation 

Variables: 

Variable names: 

 Must start with a letter 

 May contain only letters, digits, and the underscore “_” 

  Mat lab is case sensitive, i.e. one & One are different variables. 

  Mat lab only recognizes the first 31 characters in a variable name. 

 Assignment statement: 

  Variable = number; 

  Variable = expression; 

  Example: 
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>> Tutorial = 1234;    

>> Tutorial = 1234 

Tutorial = 

1234 

 

Special variables: 

 and : default variable name for the result 

 Pi:  π= 3.1415926………… 

 esp.:  € = 2.2204e-016, smallest amount by which 2 numbers can differ. 

 In or in : ∞, infinity 

 Nan or nan: not-a-number 

Commands involving variables: 

 who: lists the names of defined variables 

 whos: lists the names and sizes of defined variables 

 clear: clears all variables, reset the default values of special variables. 

 clear name: clears the variable name 

 clc: clears the command window 

  clf: clears the current figure and the graph window. 

Assignments: 

i. Write a program which performs all arithmetic operations between two variables. 

ii. Write a program which perform square root of a number. 

iii. Write a program which performs loop operations… 

iv. Write a program in which all operations should be performed which are defining in the 

previous syntax... 

v. Solve the following equations 

Y= x
2
+3x+1; 

Y= Sin(x) + 2y; 

Y= Sin(x) + Cos(x) + Tan(x); 

  

NOTE: when a semi-colon 

”;” is placed at the end of each command, the result is not displayed. 
 



Department of Computer Engineering Page 45 
 

Lab Session 7-B Introduction to Vectors in Matlab 
 
Objective:  To understand about the vectors and different operations on vectors in MATLAB. 

 

Equipment and software: 

 Personal Computer loaded with MATLAB  

 

Operating system:Windows XP, Windows 7, Windows 8 etc... 

 

Theory: 

Almost all of Matlab‟s basic commands revolve around the use of vectors. A vector is defined by 

placing a sequence of numbers within square braces: 

>> v = [3 1] 

v =     3     1 

This creates a row vector which has the label “v”. The first entry in the vector is a 3 and the 

second entry is a 1. Note that Matlab printed out a copy of the vector after you hit the enter key. 

If you do not want to print out the result put a semi-colon at the end of the line: 

>> v = [3 1]; 

>> 

If you want to view the vector just type its label: 

>> v 

v =     3     1 

You can define a vector of any size in this manner: 

>> v = [3 1 7 -21 5 6] 

v = 3     1    7    -21    5    6 

Notice, though, that this always creates a row vector. If you want to create a column vector you 

need to take the transpose of a row vector. The transpose is defined using an apostrophe („): 

>> v = [3 1 7 -21 5 6]' 

v = 

     3 

     1 

     7 

   -21 

     5 

     6 

A common task is to create a large vector with numbers that fit a repetitive pattern. Matlab can 

define a set of numbers with a common increment using colons. For example, to define a vector 

whose first entry is 1, the second entry is 2, the third is 3, and sequentially through 8, you enter 

the following: 

>> v = [1:8] 

v =     1     2     3     4     5     6     7     8 

If you wish to use an increment other than one that you have to define the start number, the value 

of the increment, and the last number. For example, to define a vector that starts with 2 and ends 

in 4 with steps of 0.25 you enter the following: 

>> v = [2:.25:4] 

v = 
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  Columns 1 through 7 

    2.0000    2.2500    2.5000    2.7500    3.0000    3.2500    3.5000 

 

  Columns 8 through 9 

    3.7500    4.0000 

Accessing elements within a vector: 

You can view individual entries in this vector. For example to view the first entry just type in the 

following: 

>> v (1) 

Ans =     2 

This command prints out entry 1 in the vector. Also notice that a new variable called ans has 

been created. Any time you perform an action that does not include an assignment matlab will 

put the label ans on the result. 

To simplify the creation of large vectors, you can define a vector by specifying the first entry, an 

increment, and the last entry. Matlab will automatically figure out how many entries you need 

and their values. For example, to create a vector whose entries are 0, 2, 4, 6, and 8, you can type 

in the following line: 

>> 0:2:8 

ans =     0     2     4     6     8 

Matlab also keeps track of the last result. In the previous example, a variable ans is created. To 

look at the transpose of the previous result, enter the following: 

>> ans' 

ans = 

     0 

     2 

     4 

     6 

     8 

To be able to keep track of the vectors you create, you can give them names. For example, a row 

vector v can be created: 

>> v = [0:2:8] 

v =     0     2     4     6     8 

>> v 

v =     0     2     4     6     8 

>> v; 

>> v' 

ans = 

     0 

     2 

     4 

     6 

     8 
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Note that in the previous example, if you end the line with a semi- colon, the result is not 

displayed. This will come in handy later when you want to use Matlab to work with very large 

systems of equations. 

Matlab will allow you to look at specific parts of the vector. If you want to only look at the first 

three entries in a vector you can use the same notation you used to create the vector: 

>> v(1:3) 

ans =   0     2     4 

 

>> v(1:2:4) 

ans =     0     4 

>> v(1:2:4)' 

ans = 

     0 

     4 

Basic operations on vectors: 

Once you master the notation you are free to perform other operations: 

>> v(1:3)-v(2:4) 

ans =    -2    -2    -2 

For the most part Matlab follows the standard notation used in linear algebra. We will see later 

that there are some extensions to make some operations easier. For now, though, both addition 

subtractions are defined in the standard way. For example, to define a new vector with the 

numbers from 0 to -4 in steps of -1 we do the following: 

>> u = [0:-1:4] 

u = [0:-1:-4] 

u =     0    -1    -2    -3    -4 

We can now add u and v together in the standard way: 

>> u+v 

ans =     0     1     2     3     4 

Additionally, scalar multiplication is defined in the standard way. Also note that scalar division 

is defined in a way that is consistent with scalar multiplication: 

>> -2*u 

ans =     0     2     4     6     8 

>> v/3 

ans =         0    0.6667    1.3333    2.0000    2.6667 

With these definitions linear combinations of vectors can be easily defined and the basic 

operations combined: 

>> -2*u+v/3 

ans =         0    2.6667    5.3333    8.0000   10.6667 

You will need to be careful. These operations can only be carried out when the dimensions of the 

vectors allow it. You will likely get used to seeing the following error message which follows 

from adding two vectors whose dimensions are different: 

>> u+v' 

??? Error using ==> plus 

Matrix dimensions must agree. 
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Some useful commands: 

 

Assignments: 

Write a program in which user initialize two vectors and perform following operations… 

a. Addition 

b. Multiplication 

c. Subtraction 

d. Division 

e. Sin 

f. Log 

g. Transpose of all results 

h. Find the length of vectors 
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Lab#08-A: Introduction to Matrix in Matlab 

 
Objective:  To understand about the Matrix and different operations on Matrix in MATLAB. 

 

Equipment and software:   Personal Computer loaded with MATLAB  

 

Operating system: Windows XP, Windows 7, Windows 8 etc... 

 

Theory: 

A Matrix array is two-dimensional, having both multiple rows and multiple columns, Similar to 

vector arrays: 

 It begins with [, and end with ] 

 Spaces or commas are used to separate elements in a row 

 Semicolon or enter is used to separate rows. 

Example: 

>> f = [1 2 3; 4 5 6] 

f = 

1 2 3 

4 5 6 

>> h = [ 2 4 6 

1 3 5] 

h = 

2 4 6 

1 3 5 

Magic Function: 

 For example you can generate a matrix by entering 

>> m=magic(4) 

It generates a matrix whose elements are such that the sum of all elements in its rows, columns 

and diagonal elements are same 

 Sum Function: 

 You can verify the above magic square by entering 

>> sum(m) 

 For rows take the transpose and then take the sum 

>> sum(m‟) 

 Diag: 

 You can get the diagonal elements of a matrix by entering 

>> d=diag(m) 

>> sum(d) 

Matrix Addressing: 

 matrixname(row, column) 

 colon may be used in place of a row or column reference to select the entire row 

or column. 

Recall: 

f = 

1 2 3 

4 5 6 Bold are the answers of the matrices... 
h = 

2 4 6 

1 3 5 
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Example: 

>> f(2,3) 

ans =6 

>> h(:,1) 

ans =2 

1 

Some useful commands: 

zeros(n): returns a n x n matrix of zeros 

zeros(m,n): returns a m x n matrix of zeros 

ones(n): returns a n x n matrix of ones 

ones(m,n): returns a m x n matrix of ones 

rand(n): returns a n x n matrix of random number 

rand(m,n): returns a m x n matrix of random number 

size (A): for a m x n matrix A, returns the row vector [m,n] containing the number of rows and 

columns in matrix. 

length(A): returns the larger of the number of rows or columns in A. 

Some other useful commands given below… 

Assignments: 

Write a program in which user take two matrices and perform following operations... 

 Transpose 

 Scalar Multiplication 

 Matrix Multiplication 
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 Matrix Inverse 

 Matrix Powers 

 Determinant 

 Identity Matrix 

 Addition and subtraction 
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Lab#08 -B: Plotting in MATLAB 
 

Objective:   To understand about the graphs plotting using MATLAB. 

 

Equipment and software: 

 Personal Computer loaded with MATLAB  

 

Operating system: 

Windows XP, Windows 7, Windows 8 etc... 

 

Theory: 

For more information on 2-D plotting, type help graph2d 

Plotting a point: 

>> plot ( variablename, „symbol‟) 

The function plot () creates a graphics window, called a Figure window, and named by default 

“Figure No. 1” 

Example:  

Complex number 

>> z = 1 + 0.5j; 

>> plot (z, „.‟) 

Commands for axes: 

Plotting Curves: 

plot (x,y) – generates a linear plot of the values of x (horizontal axis) and y (vertical axis). 

 semilogx (x,y) – generate a plot of the values of x and y using a logarithmic scale for x and a 

linear scale for y 

 semilogy (x,y) – generate a plot of the values of x and y using a linear scale for x and a 

logarithmic scale for y. 

 loglog(x,y) – generate a plot of the values of x and y using logarithmic scales for both x and y 

Multiple Curves: 

 plot (x, y, w, z) – multiple curves can be plotted on the same graph by using multiple arguments 

in a plot command. The variables x, y, w, and z are vectors. Two curves will be plotted: y vs. x, 

and z vs. w. 
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 legend (‘string1’, ‘string2’,…) – used to distinguish between plots on the same graph 

Multiple Figures: 

figure (n) – used in creation of multiple plot windows. place this command before the plot() 

command, and the corresponding figure will be labeled as “Figure n” 

close – closes the figure n window. 

close all – closes all the figure windows. 

Subplots: 

 subplot (m, n, p) – m by n grid of windows, with p specifying the current plot as the p th 

window 

Example: (polynomial function) 

plot the polynomial using linear/linear scale, log/linear scale, linear/log scale, & log/log scale: 

y = 2x 2 + 7x + 9 

% Generate the polynomial: 

x = linspace (0, 10, 100); 

y = 2*x.^2 + 7*x + 9; 

% plotting the polynomial: 

figure (1); 

subplot (2,2,1), plot (x,y); 

title ('Polynomial, linear/linear scale'); 

ylabel ('y'), grid; 

subplot (2,2,2), semilogx (x,y); 

title ('Polynomial, log/linear scale'); 

ylabel ('y'), grid; 

subplot (2,2,3), semilogy (x,y); 

title ('Polynomial, linear/log scale'); 

xlabel('x'), ylabel ('y'), grid; 

subplot (2,2,4), loglog (x,y); 

title ('Polynomial, log/log scale'); 

xlabel('x'), ylabel ('y'), grid; 

Adding new curves to the existing graph: 

 Use the hold command to add lines/points to an existing plot. 

 hold on – retain existing axes, add new curves to current axes. Axes are rescaled when 

necessary. 

hold off – release the current figure window for new plots 

Grids and Labels: 
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Additional commands for plotting: 

Assignmetns: 

Use Matlab command to obtain the following 

i. Extract the fourth row of the matrix generated by magic(6) 

ii. Show the results of „x‟ multiply by „y‟ and „y‟ divides by „x‟. 

Given x = [0:0.1:1.1] and y = [10:21] 

iii. Generate random matrix „r‟ of size 4 by 5 with number varying between -8 and 9 

Use MATLAB commands to get exactly as the figure shown below 

x=pi/2:pi/10:2*pi; 
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y=sin(x); 

z=cos(x); 

 

 

 

 


